Ad Widget

Collapse

Ubuntu 18.04 LTS Package Dependency failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ubuntu 18.04 LTS Package Dependency failure

    Hello Everyone,

    I'm trying to install Zabbix on a fresh Ubuntu 18.04 LTS server. I've set the server up and run apt update;apt upgrade.

    When I follow the install guidelines I get the following errors when trying to install from the package.

    The following packages have unmet dependencies:
    zabbix-server-mysql : Depends: libiksemel3 (>= 1.2) but it is not installable
    Depends: libssh2-1 (>= 1.0) but it is not installable
    Depends: fping but it is not installable
    Recommends: virtual-mysql-server
    Recommends: snmpd but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    [email protected]:~# apt install zabbix-server-mysql zabbix-frontend-php zabbix-agent
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    zabbix-frontend-php : Depends: ttf-dejavu-core but it is not installable or
    ttf-japanese-gothic but it is not installable
    Depends: php-mbstring but it is not installable
    Depends: php-bcmath but it is not installable
    zabbix-server-mysql : Depends: libiksemel3 (>= 1.2) but it is not installable
    Depends: libssh2-1 (>= 1.0) but it is not installable
    Depends: fping but it is not installable
    Recommends: virtual-mysql-server
    Recommends: snmpd but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    To get some troubleshooting out of the way, yes, I have run the correct wget command for 18.04 which is bionic if I'm reading this right. I have blown away the server and it is as fresh as it can be. Do I need some other dependency that isn't in the documentation?

    When I do apt list --installed here is what I see for Zabbix:

    zabbix-release/unknown,now 3.4-1+bionic all [installed]

    Is there something wrong with the package? Any help is appreciated.

    #2
    It seems that you can not install the package that needs to be obtained from Ubuntu's repository and installed.
    Please check that it is set in /etc/apt/sources.list so that you can access not only main but also universe etc.

    Comment


      #3
      Thanks for the response. I will try that and report back if there are any issues.

      Comment


        #4
        I just wanted to say that this got me on the right track. I had to add the following lines to the /etc/apt/sources.list

        ###### Ubuntu Main Repos
        deb http://us.archive.ubuntu.com/ubuntu/ bionic main universe
        deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main universe

        ###### Ubuntu Update Repos
        deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main universe
        deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main universe
        deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-security main universe
        deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates main universe

        Comment

        Announcement

        Collapse
        No announcement yet.
        Working...
        X