Ad Widget

Collapse

Another Zabbix server is not running topic - tried all the solutions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Another Zabbix server is not running topic - tried all the solutions

    Server 1:
    mysql_1 - replicated with 2
    zabbix_server

    Server 2:
    mysql_2 - replicated with 1
    zabbix_web

    The zabbix server is running:
    $ sudo systemctl status zabbix-server
    ‚óŹ zabbix-server.service - Zabbix Server
    Loaded: loaded (/usr/lib/systemd/system/zabbix-server.service; disabled; vendor preset: disabled)
    Active: active (running) since Qua 2019-06-12 15:29:09 -03; 8min ago
    Process: 116117 ExecStop=/bin/kill -SIGTERM $MAINPID (code=exited, status=0/SUCCESS)
    Process: 116122 ExecStart=/usr/sbin/zabbix_server -c $CONFFILE (code=exited, status=0/SUCCESS)
    Main PID: 116124 (zabbix_server)
    CGroup: /system.slice/zabbix-server.service

    The port 10051 is open to server 2:
    $ telnet server1addres 10051
    Trying X.X.X.X ...
    Connected to server1addres.
    Escape character is '^]'.



    Config is correct (double checked )
    $ZBX_SERVER = 'X.X.X.X';
    $ZBX_SERVER_PORT = '10051';
    $ZBX_SERVER_NAME = 'zabbix_server';

    The server is shown off:
    Zabbix server is running No X.X.X.X:10051

    No error on zabbix-server log

    Selinux is disabled:
    $ sestatus
    SELinux status: disabled



    zabbix-server.conf:

    LogFile=/var/log/zabbix/zabbix_server.log
    LogFileSize=10
    DebugLevel=3
    PidFile=/var/run/zabbix/zabbix_server.pid
    SocketDir=/var/run/zabbix
    DBHost=localhost
    DBName=zabbix
    DBUser=zabbix
    DBPassword=DB_PASSWORD
    DBPort=3306
    StartPollers=32
    StartPollersUnreachable=128
    StartTrappers=16
    StartPingers=16
    SNMPTrapperFile=/var/log/snmptrap/snmptrap.log
    HousekeepingFrequency=0
    CacheSize=1G
    CacheUpdateFrequency=300
    StartDBSyncers=5
    HistoryCacheSize=128M
    HistoryIndexCacheSize=128M
    TrendCacheSize=512M
    ValueCacheSize=512M
    Timeout=30
    UnreachablePeriod=60
    UnavailableDelay=120
    UnreachableDelay=30
    AlertScriptsPath=/usr/lib/zabbix/alertscripts
    ExternalScripts=/usr/lib/zabbix/externalscripts
    LogSlowQueries=3000
    AllowRoot=1
    StatsAllowedIP=127.0.0.1

    The database options are correct, since the server is running

    Any ideas?







    I had resolved it, remade the database replication...

    Last edited by 1berto; 13-06-2019, 00:51.

Announcement

Collapse
No announcement yet.
Working...
X