Ad Widget

Collapse

Error connecting to database after upgrade

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Error connecting to database after upgrade

    [SOLVED]
    Solution: In the 4.2.6 version a default database password was set in the file zabbix/web/zabbix.conf.php

    Hi, new here - so please bear with me

    OS Ubuntu 18.04LTS

    Today I upgraded my Zabbix from 4.0.9 to 4.2.6

    When trying to access web UI afterwards I am getting "Error connecting to database: Access denied for user 'zabbix'@'localhost' (using password: YES)"

    * In /var/log/zabbix/zabbix_server.log everything seems to be running fine and it is connecting to the database. I also can see my items becoming supported in the log.
    * I am able to connect to the database using the credentials from zabbix_server.conf from Chrome MySQL-Admin.
    * If I change the mysql-credentials in zabbix_server.conf I can see in the log that zabbix is not able to connect to mySQL.
    * If I remove the password from mySQL and zabbix_server.conf I still get the "(using password: YES)"-error
    * I have granted all rights on the zabbix dbuser and flushed privileges after every password change on mysql

    Is there some other place where the database credentials needs to be updated?

    And yes, I do restart the zabbix-server service between every test
    Zabbix Agent is turned off

    Anyone with any good advice what is causing this?
    Last edited by emlben; 13-09-2019, 09:01.

    #2
    Solved it!
    Needed to set the database password in the file zabbix/web/zabbix.conf.php.
    The default password found in that file was not something I put there. So a glitch in the update procedure...

    Comment

    Working...
    X