Announcement

Collapse
No announcement yet.

centos 7

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    centos 7

    cant install zabbix2.2 server pgsql

    yum failed on dependency check
    ****************
    Error: Package: zabbix-server-pgsql-2.2.6-1.el6.x86_64 (zabbix)
    Requires: libnetsnmp.so.20()(64bit)
    ****************

    [[email protected] ~]# ls -l /usr/lib64/libnetsnmpmibs.so.31
    lrwxrwxrwx. 1 root root 24 Aug 29 02:04 /usr/lib64/libnetsnmpmibs.so.31 -> libnetsnmpmibs.so.31.0.2

    and

    [[email protected] ~]# env | grep LD
    LDFLAGS=-Wl,-R,/usr/lib64/
    LD_LIBRARY_PATH=/usr/lib64


    Is there any way to install zabbix 2.2 on centos 7?

    #2
    Package: zabbix-server-pgsql-2.4.3 Requires: libnetsnmp.so.20

    Good day,

    At first failed to install 2.4.2 because of the dependence on libnetsnmp.so.20

    then installed from the package (https://support.zabbix.com/browse/ZBXNEXT-2532)

    yum -y install zabbix-2.4.2-1.el7.x86_64.rpm zabbix-server-2.4.2-1.el7.x86_64.rpm zabbix-server-pgsql-2.4.2-1.el7.x86_64.rpm

    and now cant update to 2.4.3 because of the dependence on libnetsnmp.so.20

    ************************************************** ***
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.tversu.ru
    * epel: mirror.euserv.net
    * extras: mirror.tversu.ru
    * ius: download.srv.ro
    * updates: mirror.tversu.ru
    Resolving Dependencies
    --> Running transaction check
    ---> Package zabbix.x86_64 0:2.4.2-1.el7 will be updated
    ---> Package zabbix.x86_64 0:2.4.3-1.el6 will be an update
    ---> Package zabbix-agent.x86_64 0:2.4.2-1.el7 will be updated
    ---> Package zabbix-agent.x86_64 0:2.4.3-1.el6 will be an update
    ---> Package zabbix-server.x86_64 0:2.4.2-1.el7 will be updated
    ---> Package zabbix-server.x86_64 0:2.4.3-1.el6 will be an update
    ---> Package zabbix-server-pgsql.x86_64 0:2.4.2-1.el7 will be updated
    ---> Package zabbix-server-pgsql.x86_64 0:2.4.3-1.el6 will be an update
    --> Processing Dependency: libnetsnmp.so.20()(64bit) for package: zabbix-server-pgsql-2.4.3-1.el6.x86_64
    ---> Package zabbix-web.noarch 0:2.4.2-1.el6 will be updated
    ---> Package zabbix-web.noarch 0:2.4.3-1.el6 will be an update
    ---> Package zabbix-web-pgsql.noarch 0:2.4.2-1.el6 will be updated
    ---> Package zabbix-web-pgsql.noarch 0:2.4.3-1.el6 will be an update
    --> Finished Dependency Resolution
    Error: Package: zabbix-server-pgsql-2.4.3-1.el6.x86_64 (zabbix)
    Requires: libnetsnmp.so.20()(64bit)
    You could try using --skip-broken to work around the problem
    ************************************************** ***

    CentOS 7.0.1406: Linux version 3.10.0-123.13.1.el7.x86_64

    Comment


      #3
      Same story
      Because of that I rolled back to CentOS release 6.6 (Final)
      Sincerely yours,
      Aleksey

      Comment

      Working...
      X