Ad Widget

Collapse

installation error: frontend does not match Zabbix database

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    installation error: frontend does not match Zabbix database

    I recently installed Centos 6.5 as a VBox guest. I then installed Zabbix 2.2 with the package manager. I also installed MySQL 5.1.73 and phpMyAdmin.

    I created a mySQL DB called "zabbix", with collation = utf8_unicode_ci.

    I then brought up Zabbix as localhost/zabbix, which gave me the Installation dialog. On the "configure DB connection" page, I put in my root password for MySQL.

    When I clicked on "Test connection", I get the message "The frontend does not match Zabbix database. I've searched everywhere, in this forum and elsewhere, but I can't find an explanation for this message.

    What does this mean and how can I fix it?

    UPDATE: zabbix log entry: [Z3001] connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: NO)

    But I can't find what's causing this

    UPDATE: I found 3 threads that ask the same question. They all stop without resolution. They also all report the problem in Zabbix 2.2.
    So maybe I'll downgrade to 2.0 (which they say works), or I'll install 2.4 from source and hope it's fixed there.

    BTW, can anyone tell me what in the source code triggers this error?


    Thanks.
    Last edited by oksofar; 14-10-2014, 02:38. Reason: New information

    #2
    Frontend error zabbix 2.4

    I haver same problem with zabbix 2.4.1 when i try to install it . I can log in the database with zabbix user , so its intresting what is this problem .
    Attached Files

    Comment


      #3
      Configure DB connection: frontend does not match Zabbix database

      with Ubuntu 14.04 and zabbix 2.4 same problem:

      The frontend does not match Zabbix database during step 3 configure DB connection ...

      Comment


        #4
        installation error: frontend does not match Zabbix database

        My solution :
        ref:https://www.zabbix.com/documentation...all/db_scripts

        drop existing zabbix db

        then

        shell> mysql -u<username> -p<password>
        mysql> create database zabbix character set utf8 collate utf8_bin;
        mysql> quit;
        shell> mysql -u<username> -p<password> zabbix < database/mysql/schema.sql
        # stop here if you are creating database for Zabbix proxy
        shell> mysql -u<username> -p<password> zabbix < database/mysql/images.sql
        shell> mysql -u<username> -p<password> zabbix < database/mysql/data.sql

        after that step 3 is ok...

        Comment

        Working...
        X