Ad Widget

Collapse

Preprocessing Manager high Memory load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Preprocessing Manager high Memory load

    We are using Zabbix version 3.4.0, we have 1 server(16GB RAM), 2 proxies both virtual machines with 16GB RAM, and 1 DBserver(running MySQL) also with 16GB RAM. We have a pretty big environment with about 3500 hosts(currently we enabled only about 2500 of them) with ~850.000 of items(currently we enabled only about 450.144 of them). All the items are SNMPv2 items.

    The problems is that both proxies are doing well, we have no queues on them, and on both we have about 30% of free RAM, but on the server, we have 1 process which cause a very high memory load - preprocessing manager #1. Preprocessing manager take about 80% of memory load, and I am not sure if it is normal... As I read, if we use active proxies, most of the load should fall on them, and the server should just get all the values from proxies, and send them to DB, so it shouldn't have high load..

    Also, I noticed that my server has low value cache effectiveness. Graphs shows that server on average has about 800vps, while I saw that in other, much smaller environments, Zabbix Server used more then 5-10kvps... ValueCacheSize parameter in zabbix_server.cfg is set to 2G but, I tried different sizes, from 1Mb to 5G and in all cases, when I looked at "Zabbix Cache Usage % free" graph, I Value Cache Size was always 100% free, even with 1M ValueCacheSize...

    When I look at Data Gathering Processes, there is no process with high load, all the processes has an average of 1-2% of load... in Zabbix Server Performance, my proxies has about 1.5k of values processed per seconds, and I have no queue, while on server,I also have about 1.6k values processed per seconds, and most of the time, I see about 4k-9k of queues..

    Can anybody help me?

    Click image for larger version

Name:	server-cache-usage.jpeg
Views:	1
Size:	20.1 KB
ID:	318342
    Click image for larger version

Name:	server-data-gathering-process-busy.jpeg
Views:	1
Size:	23.8 KB
ID:	318343
    Click image for larger version

Name:	value-cache-effecteveness.jpeg
Views:	1
Size:	17.0 KB
ID:	318344
    Click image for larger version

Name:	zabbix-server.jpeg
Views:	1
Size:	91.2 KB
ID:	318345
    Click image for larger version

Name:	zabbix-server-performance.jpeg
Views:	1
Size:	21.5 KB
ID:	318346

    #2
    Help..

    Nobody can help me ? Or at least give an advice?

    Comment


      #3
      Solution on the way

      Hi Andrew,

      we are facing the same problem. I opened a case at support.zabbix.com and it looks like the problem was solved by within minutes :-)

      Take a look at https://support.zabbix.com/browse/ZBX-12919

      Best regards
      Andi

      Comment

      Announcement

      Collapse
      No announcement yet.
      Working...
      X