Zabbix Documentation 2.4

3.04.04.4 (current)| In development:5.0 (devel)| Unsupported:1.82.02.22.43.23.44.2Guidelines

User Tools

Site Tools


ru:manual:installation:install

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
ru:manual:installation:install [2015/12/21 10:07]
dotneft
ru:manual:installation:install [2016/12/06 11:32] (current)
dotneft
Line 1: Line 1:
 ==== 4 Установка из исходных кодов ==== ==== 4 Установка из исходных кодов ====
 +
  
 Вы можете получить самую свежую версию Zabbix, скомпилировав его из исходных кодов. Вы можете получить самую свежую версию Zabbix, скомпилировав его из исходных кодов.
Line 185: Line 186:
 |//​mbstring// ​ |  |php-mbstring ​ | |//​mbstring// ​ |  |php-mbstring ​ |
 |//PHP опция mbstring.func_overload// ​ |должна быть отключена ​ |В php.ini:\\ mbstring.func_overload = 0.  | |//PHP опция mbstring.func_overload// ​ |должна быть отключена ​ |В php.ini:\\ mbstring.func_overload = 0.  |
-|//PHP опция always_populate_raw_post_data// ​ |должна быть ​равной -1 |Требуется только для версий PHP 5.6.0 и новее.\\ В php.ini:\\ always_populate_raw_post_data = -1 |+|//PHP опция always_populate_raw_post_data// ​ |должна быть отключена ​|Требуется только для версий PHP 5.6.0 и новее.\\ В php.ini:\\ always_populate_raw_post_data = -1 |
 |//​sockets// ​ |  |php-net-socket. Требуется для поддержки пользовательских скриптов. ​  | |//​sockets// ​ |  |php-net-socket. Требуется для поддержки пользовательских скриптов. ​  |
 |//​gd// ​ |2.0 или выше ​ |php-gd. Расширение PHP GD должно поддерживать PNG изображения (//<​nowiki>​--with-png-dir</​nowiki>//​),​ JPEG (//<​nowiki>​--with-jpeg-dir</​nowiki>//​) изображения и FreeType 2 (//<​nowiki>​--with-freetype-dir</​nowiki>//​). | |//​gd// ​ |2.0 или выше ​ |php-gd. Расширение PHP GD должно поддерживать PNG изображения (//<​nowiki>​--with-png-dir</​nowiki>//​),​ JPEG (//<​nowiki>​--with-jpeg-dir</​nowiki>//​) изображения и FreeType 2 (//<​nowiki>​--with-freetype-dir</​nowiki>//​). |
Line 193: Line 194:
 |//​ctype// ​ |  |php-ctype ​ | |//​ctype// ​ |  |php-ctype ​ |
 |//​session// ​ |  |php-session ​ | |//​session// ​ |  |php-session ​ |
-|//​gettext// ​ |  |php-gettext\\ Начиная с **Zabbix 2.2.1**, расширение ​php get text более не является обязательным для установки Zabbix. Если gettext не установлен,​ веб-интерфейс будет работать как обычно,​ однако,​ переводы будут недоступны. ​ |+|//​gettext// ​ |  |php-gettext\\ Начиная с Zabbix 2.2.1, расширение ​PHP gettext ​более не является обязательным для установки Zabbix. Если gettext не установлен,​ веб-интерфейс будет работать как обычно,​ однако,​ переводы будут недоступны. ​ |
  
 В списке могут также присутствовать необязательные требования. Если необязательное требование не удволетворено,​ то оно отображатеся оранжевым цветом и имеет состояние Предупреждение (Warning). Установка может продолжатся,​ если необязательные требования не удовлетворены. В списке могут также присутствовать необязательные требования. Если необязательное требование не удволетворено,​ то оно отображатеся оранжевым цветом и имеет состояние Предупреждение (Warning). Установка может продолжатся,​ если необязательные требования не удовлетворены.