Ad Widget

Collapse

Latest data shows items with info "Value is not available"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Latest data shows items with info "Value is not available"

    Problem:
    • Selecting Monitor > Latest Data > Show details, some VMs will show "value is not available" for (what seems) random simple check items.

    Trouble shooting:
    • Tried rebooting VM in question.
    • Tried rebooting zabbix.
    • Tried resting snmp service on host.
    • Tried deploying a new Zabbix server 4.2.5, and integrate vmware templates, adding the host so VMs will get discovered. Same error messages appear for the same guests on the production zabbix.
    • Tried upgrading Zabbix to the latest 5.0.1
    • Narrowed this down to problems with simple check to ESXi hosts.
    • Does not seem to be any rhyme or reason to why one VM will be able to show (example) CPU usage, but a different VM on a different host on a different VM the same item shows "value not available"
    • Reviewed zabbix_server.logs and zabbix_agent.logs, There are many items that read "became not supported: Couldn't connect to server" or "became not supported: value not available", these log entries are too general and I assume could mean a variety of things which may not be associated to the problem, are there any other logs I can dig in?
    • Found this post https://www.zabbix.com/forum/zabbix-...-not-available however there does not look like anyone has updated it.
    • Tried moving virtual machines between hosts. (This seemed to fix the issue for some of the settings. Note we do not have a cluster / shared storage, so vmotion was not possible. Had to move VM's via datastore "moves")
    • Checked config.vpxd.stats.maxQueryMetrics was set correctly in vCenter advanced features.

      What is going on here? What is causing random items in discovery of VMs to all of a sudden show "value is not available" now?

Announcement

Collapse
No announcement yet.
Working...
X