Ad Widget

Collapse

Zabbix is not use syslog!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix is not use syslog!

    Hello, i am a french user of zabbix,
    I am using zabbix 1.0 release, because i am in a production envirronement
    first : thanks for your jobs, zabbix is a great monitoring tool.

    second :I have some problems :
    although in the configuration files of zabbix_suckerd and zabbix_agentd, i'm not use the "LogFile" parameter, zabbix is not using syslog.
    In syslog.conf i have write :
    "*.* /var/log/allmessages"
    and i create this files, and reload syslog
    but there's no trace of zabbix in /var/log/allmessages
    of course i can use the logfile but in this way, i can't export the log to another server.

    until i resolv this problem i am using the logfile.
    if anyone know how to resolve my probleme?
    thank you in advance

    #2
    i've never used the syslog daemon to log messages from Zabbix, i've always used the log files that Zabbix generates on it's own.
    I'm not sure, but i think you can push messages to the syslog daemon, but unfortunately i don't know how exactly.

    Perhaps someone else can throw some light on this.

    Comment


      #3
      thank you for your answer

      Comment


        #4
        Is anyone use syslogd instead of the log file?

        Comment


          #5
          I have exactly the same problem. Not setting LogFile or setting it to nothing ("LogFile=") deactivates logging, nothing ever reaches syslog. I'm using Zabbix 1.4 and syslog-ng 1.6.11 on Gentoo. Is this a bug or am I doing something wrong?

          Bye,
          Kevin

          Comment


            #6
            Originally posted by kevinschmidt
            I have exactly the same problem. Not setting LogFile or setting it to nothing ("LogFile=") deactivates logging, nothing ever reaches syslog. I'm using Zabbix 1.4 and syslog-ng 1.6.11 on Gentoo. Is this a bug or am I doing something wrong?

            Bye,
            Kevin
            Try this:
            /usr/bin/logger -p local0.err -t zabbix -u /var/log/zabbix-server/zabbix-server.log

            See if zabbix can log into socket instead of log file (probably log rotation should be turned off & logfile deleted).

            Comment


              #7
              Thanks for reporting this problem.
              Alexei Vladishev
              Creator of Zabbix, Product manager
              New York | Tokyo | Riga
              My Twitter

              Comment


                #8
                also the same issue in 1.6. any news about that ?

                Comment


                  #9
                  Patch

                  --- src/libs/zbxlog/log.c.orig 2010-01-29 15:49:19.000000000 +0300
                  +++ src/libs/zbxlog/log.c 2010-01-29 15:49:33.000000000 +0300
                  @@ -109,7 +109,6 @@
                  #else /* not _WINDOWS */

                  openlog("zabbix_suckerd", LOG_PID, LOG_USER);
                  - setlogmask(LOG_UPTO(LOG_WARNING));

                  #endif /* _WINDOWS */
                  }

                  Comment

                  Announcement

                  Collapse
                  No announcement yet.
                  Working...
                  X