configure: error: Not found mysqlclient library

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    configure: error: Not found mysqlclient library

    Hi!

    Im trying to install Zabbix 1.4.5 on an HP-UX 11.11 System-
    During :/configure the followning mistakes happen:

    checking for mysql_config... /usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/bin/mysql_config
    checking for main in -lmysqlclient ... no
    configure: error: Not found mysqlclient library


    My configure was:
    configure --with-mysql=/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/bin/mysql_config \
    --with-net-snmp --enable-server --enable-agent

    MySQL Version is 5.1.23 64 Bit

    I tried to path the needed librarys via LDFLAGS but because of this the C Compiler gets an Error...

    Does anybody know, how to include the needes librarys in configure?

    #2
    Hi,

    I think u just have to include the PATH "--with-mysql=/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/bin/".

    See config.log for more information,

    Greets
    Patrick

    Comment


      #3
      Hi!

      Again, the same error occured...

      But the directory / path
      --with-mysql=/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/bin/

      contains only binaries- no libs...

      Comment


        #4
        Does anybody know a solution?

        Comment


          #5
          look in config.log for the detailed error message as trikke already told you.

          Comment


            #6
            try --with-mysql=/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit
            Normally you would enter the base path of the installation

            if that doesnt work try

            CPPFLAGS=-I/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/include LDFLAGS=-L/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/lib ./configure bla bla
            and
            CPPFLAGS=-I/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/include LDFLAGS=-L/usr/local/mysql-5.1.23-rc-hpux11.11-hppa2.0w-64bit/lib make all

            Comment


              #7
              1. find location of mysql lib dir and enter it
              2. there maybe have some lib file such like "libmysqlclient.so.15.0.0" and "libmysqlclient_r.so.15.0.0"
              3. make two soft links by run these two commands "ln -s libmysqlclient.so.15.0.0 libmysqlclient.so" and "ln -s libmysqlclient_r.so.15.0.0 libmysqlclient_r.so"
              4. then redo configure script

              Comment


                #8
                You guys may find this one interesting too!
                It appears that if you're on RHEL or CENTOS; libmysqlclient.a is no longer supplied and will break the "conftest" stage....


                http://bugs.centos.org/view.php?id=5083

                Comment


                  #9
                  fixed?

                  I too, I'm having the same issue on centos 6 with zabbix 3 source.

                  Have anyone fixed this?

                  Comment


                    #10
                    Originally posted by malayo View Post
                    I too, I'm having the same issue on centos 6 with zabbix 3 source.

                    Have anyone fixed this?
                    install mysql-devel

                    #yum -y install mysql-devel

                    you'll probably also need to install other packages needed later on.

                    Comment

                    Announcement

                    Collapse
                    No announcement yet.
                    Working...
                    X