Sidebar

ru:manual:appendix:compatibility

14 Совместимость версий

Поддерживаемые агенты

Zabbix агенты начиная с 1.4 версии совместимы с Zabbix 4.4. Однако, возможно вам потребуется пересмотреть конфигурацию старых агентов, так как некоторые параметры могли измениться, например, параметры связанные с журналированием по сравнению с версиями до 3.0.

Чтобы воспользоваться всеми преимуществами новых и улучшенных элементов данных, улучшенной производительности и уменьшенным использованием памяти, используйте последнюю версию агента 4.4.

Обратите внимание, что Zabbix агент 4.4 нельзя использовать с Zabbix серверами старее чем 4.4.

Поддерживаемые Zabbix прокси

Zabbix 4.4.x сервер может работать только с Zabbix 4.4.x прокси. Zabbix 4.4.x прокси могут работать только с Zabbix 4.4.x сервером.

Более невозможно запустить обновленный сервер и более старые, не обновленные прокси, которые бы отправляли данные на более новый сервер. Такой подход, который никогда не рекомендовался и не поддерживался в Zabbix, теперь официально отключён, так как сервер будет игнорировать данные с не обновленных прокси. Для получения более подробных сведений, смотрите процедуру обновления.

Предупреждения об использовании несовместимых версий Zabbix демонов вносится в журнал.

Поддержка XML файлов

XML файлы, экспортированные в версиях 1.8, 2.0, 2.2, 2.4, 3.0, 3.2, 3.4, 4.0 и 4.2 поддерживаются при импорте в версию Zabbix 4.4.

В XML формате Zabbix 1.8 при экспорте, зависимости триггеров сортируются только по названию. Если имеется несколько триггеров с одинаковым именем (например, имеющие разные важности и выражения), которые имеют заданную зависимость между собой, то их невозможно импортировать. Такие зависимости должны быть удалены вручную из файла XML и добавлены после импорта.