Zabbix Documentation 5.2

3.04.05.0 (current)| In development:5.2 (devel)| Unsupported:1.82.02.22.43.23.44.24.4Guidelines

User Tools

Site Tools


manual:installation:containers

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
manual:installation:containers [2020/05/20 06:50]
martins-v updating page content in line with latest changes in 5.0
manual:installation:containers [2020/05/20 06:54] (current)
martins-v 5.0 -> 5.2
Line 47: Line 47:
   * ''​alpine-latest''​ - latest stable version of a Zabbix component based on Alpine Linux image   * ''​alpine-latest''​ - latest stable version of a Zabbix component based on Alpine Linux image
   * ''​ubuntu-latest''​ - latest stable version of a Zabbix component based on Ubuntu image   * ''​ubuntu-latest''​ - latest stable version of a Zabbix component based on Ubuntu image
-  * ''​alpine-5.0-latest''​ - latest minor version of a Zabbix 5.component based on Alpine Linux image +  * ''​alpine-5.2-latest''​ - latest minor version of a Zabbix 5.component based on Alpine Linux image 
-  * ''​ubuntu-5.0-latest''​ - latest minor version of a Zabbix 5.component based on Ubuntu image +  * ''​ubuntu-5.2-latest''​ - latest minor version of a Zabbix 5.component based on Ubuntu image 
-  * ''​alpine-5.0.*''​ - different minor versions of a Zabbix 5.component based on Alpine Linux image, where ''​*''​ is the minor version of Zabbix component +  * ''​alpine-5.2.*''​ - different minor versions of a Zabbix 5.component based on Alpine Linux image, where ''​*''​ is the minor version of Zabbix component 
-  * ''​ubuntu-5.0.*''​ - different minor versions of a Zabbix 5.component based on Ubuntu image, where ''​*''​ is the minor version of Zabbix component+  * ''​ubuntu-5.2.*''​ - different minor versions of a Zabbix 5.component based on Ubuntu image, where ''​*''​ is the minor version of Zabbix component
  
 === Usage === === Usage ===
Line 240: Line 240:
 There are a few different versions of compose files: There are a few different versions of compose files:
 |  **File name** ​ |  **Description** ​ | |  **File name** ​ |  **Description** ​ |
-|''​docker-compose_v3_alpine_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Alpine Linux with MySQL database support. | +|''​docker-compose_v3_alpine_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Alpine Linux with MySQL database support. | 
-|''​docker-compose_v3_alpine_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Alpine Linux with MySQL database support. | +|''​docker-compose_v3_alpine_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Alpine Linux with MySQL database support. | 
-|''​docker-compose_v3_alpine_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Alpine Linux with PostgreSQL database support.| +|''​docker-compose_v3_alpine_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Alpine Linux with PostgreSQL database support.| 
-|''​docker-compose_v3_alpine_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Alpine Linux with PostgreSQL database support.| +|''​docker-compose_v3_alpine_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Alpine Linux with PostgreSQL database support.| 
-|''​docker-compose_v3_centos_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on CentOS 7 with MySQL database support. | +|''​docker-compose_v3_centos_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on CentOS 7 with MySQL database support. | 
-|''​docker-compose_v3_centos_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on CentOS 7 with MySQL database support. | +|''​docker-compose_v3_centos_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on CentOS 7 with MySQL database support. | 
-|''​docker-compose_v3_centos_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on CentOS 7 with PostgreSQL database support.| +|''​docker-compose_v3_centos_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on CentOS 7 with PostgreSQL database support.| 
-|''​docker-compose_v3_centos_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on CentOS 7 with PostgreSQL database support.| +|''​docker-compose_v3_centos_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on CentOS 7 with PostgreSQL database support.| 
-|''​docker-compose_v3_ubuntu_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Ubuntu 18.04 with MySQL database support.| +|''​docker-compose_v3_ubuntu_mysql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Ubuntu 18.04 with MySQL database support.| 
-|''​docker-compose_v3_ubuntu_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Ubuntu 18.04 with MySQL database support.| +|''​docker-compose_v3_ubuntu_mysql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Ubuntu 18.04 with MySQL database support.| 
-|''​docker-compose_v3_ubuntu_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Ubuntu 18.04 with PostgreSQL database support.| +|''​docker-compose_v3_ubuntu_pgsql_latest.yaml''​|The compose file runs the latest version of Zabbix 5.components on Ubuntu 18.04 with PostgreSQL database support.| 
-|''​docker-compose_v3_ubuntu_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Ubuntu 18.04 with PostgreSQL database support.|+|''​docker-compose_v3_ubuntu_pgsql_local.yaml''​|The compose file locally builds the latest version of Zabbix 5.and runs Zabbix components on Ubuntu 18.04 with PostgreSQL database support.|
  
 <note important>​Available Docker compose files support version 3 of Docker Compose.</​note>​ <note important>​Available Docker compose files support version 3 of Docker Compose.</​note>​
Line 273: Line 273:
 </​code>​ </​code>​
  
-The command will download latest Zabbix 5.images for each Zabbix component and run them in detach mode.+The command will download latest Zabbix 5.images for each Zabbix component and run them in detach mode.
  
 <note important>​Do not forget to download ''​.env_<​type of component>''​ files from github.com official Zabbix repository with compose files.</​note>​ <note important>​Do not forget to download ''​.env_<​type of component>''​ files from github.com official Zabbix repository with compose files.</​note>​
Line 283: Line 283:
 </​code>​ </​code>​
  
-The command will download base image Ubuntu 18.04 (bionic), then build Zabbix 5.components locally and run them in detach mode.+The command will download base image Ubuntu 18.04 (bionic), then build Zabbix 5.components locally and run them in detach mode.