ru:manual:installation:upgrade_packages:debian_ubuntu

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
ru:manual:installation:upgrade_packages:debian_ubuntu [2017/05/25 12:58]
dotneft created
ru:manual:installation:upgrade_packages:debian_ubuntu [2018/07/11 17:12]
dotneft removed
Line 16: Line 16:
  
   # service zabbix-proxy stop   # service zabbix-proxy stop
 +
 +<note important>​Известно,​ что имеется возможно обновления только сервера и использование старых,​ ещё не обновленные прокси будут отправлять данные на новый сервер (хотя прокси не смогут обновить свою конфигурацию). Такой поход, однако,​ не рекомендуется и не поддерживается Zabbix и, выбирая его, вы действуете на свой страх и риск.</​note>​
  
 == 2 Резервная копия существующей базы данных Zabbix == == 2 Резервная копия существующей базы данных Zabbix ==
Line 26: Line 28:
  
 Файлы конфигурации:​ Файлы конфигурации:​
-  # cp /​etc/​zabbix/​zabbix_server.conf /​opt/​zabbix-backup +  ​# mkdir /​opt/​zabbix-backup/​ 
-  # cp /etc/httpd/conf.d/​zabbix.conf ​ /​opt/​zabbix-backup+  ​# cp /​etc/​zabbix/​zabbix_server.conf /​opt/​zabbix-backup/ 
 +  # cp /etc/apache2/conf-enabled/​zabbix.conf /​opt/​zabbix-backup/
  
 Файлы PHP и бинарные файлы Zabbix: Файлы PHP и бинарные файлы Zabbix:
-  # cp -R /​usr/​share/​zabbix/​ /​opt/​zabbix-backup +  # cp -R /​usr/​share/​zabbix/​ /​opt/​zabbix-backup/ 
-  # cp /​usr/​share/​doc/​zabbix-* /​opt/​zabbix-backup+  # cp -R /​usr/​share/​doc/​zabbix-* /​opt/​zabbix-backup/
   ​   ​
 == 4 Обновите пакет конфигурации репозитория == == 4 Обновите пакет конфигурации репозитория ==
Line 37: Line 40:
 Чтобы продолжить обновление,​ необходимо удалить пакет текущий репозитория. Чтобы продолжить обновление,​ необходимо удалить пакет текущий репозитория.
  
-  # rm -Rf /​etc/​apt/​sources.list.d/​zabbix.repo+  # rm -Rf /​etc/​apt/​sources.list.d/​zabbix.list
  
 Затем установить пакет нового репозитория. Затем установить пакет нового репозитория.
  
-Для **Debian ​7** выполните:​ +Для **Debian ​9** выполните:​ 
-  # wget http://​repo.zabbix.com/​zabbix/​3.2/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.2-1+wheezy_all.deb +  # wget http://​repo.zabbix.com/​zabbix/​3.4/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+stretch_all.deb 
-  # dpkg -i zabbix-release_3.2-1+wheezy_all.deb+  # dpkg -i zabbix-release_3.4-1+stretch_all.deb
   ​   ​
 Для **Debian 8** выполните:​ Для **Debian 8** выполните:​
-  # wget http://​repo.zabbix.com/​zabbix/​3.2/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.2-1+jessie_all.deb +  # wget http://​repo.zabbix.com/​zabbix/​3.4/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+jessie_all.deb 
-  # dpkg -i zabbix-release_3.2-1+jessie_all.deb+  # dpkg -i zabbix-release_3.4-1+jessie_all.deb
   ​   ​
-Для **Ubuntu 14.04** выполните:​ +Для **Debian 7** выполните:​ 
-  # wget http://​repo.zabbix.com/​zabbix/​3.2/ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.2-1+trusty_all.deb +  # wget http://​repo.zabbix.com/​zabbix/​3.4/debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+wheezy_all.deb 
-  # dpkg -i zabbix-release_3.2-1+trusty_all.deb+  # dpkg -i zabbix-release_3.4-1+wheezy_all.deb 
 +   
 +Для **Ubuntu 18.04** выполните:​
  
-Для **Ubuntu 16.06** выполните:​+  # wget http://​repo.zabbix.com/​zabbix/​3.4/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+bionic_all.deb 
 +  # dpkg -i zabbix-release_3.4-1+bionic_all.deb 
 + 
 +Для **Ubuntu 16.04** выполните:​ 
 + 
 +  # wget http://​repo.zabbix.com/​zabbix/​3.4/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+xenial_all.deb 
 +  # dpkg -i zabbix-release_3.4-1+xenial_all.deb 
 + 
 +Для **Ubuntu 14.04** выполните:​
  
-  # wget http://​repo.zabbix.com/​zabbix/​3.2/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.2-1+xenial_all.deb +  # wget http://​repo.zabbix.com/​zabbix/​3.4/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.4-1+trusty_all.deb 
-  # dpkg -i zabbix-release_3.2-1+xenial_all.deb+  # dpkg -i zabbix-release_3.4-1+trusty_all.deb
  
 Обновите информацию о репозитории. Обновите информацию о репозитории.
Line 64: Line 77:
  
 Для обновления компонентов Zabbix вы можете выполнить что-то вроде: Для обновления компонентов Zabbix вы можете выполнить что-то вроде:
-  # apt-get install --only-upgrade zabbix-server-mysql zabbix-web-mysql zabbix-agent+  # apt-get install --only-upgrade zabbix-server-mysql zabbix-frontend-php zabbix-agent
  
 Если используете PostgreSQL, в команде замените ''​mysql''​ на ''​pgsql''​. Если обновляете прокси,​ в команде замените ''​server''​ на ''​proxy''​. ​ Если используете PostgreSQL, в команде замените ''​mysql''​ на ''​pgsql''​. Если обновляете прокси,​ в команде замените ''​server''​ на ''​proxy''​. ​
Line 70: Line 83:
 == 6 Просмотрите параметры конфигурации компонент == == 6 Просмотрите параметры конфигурации компонент ==
  
-В этой версии обязательные изменения в [[:​ru/​manual/​appendix/config/​zabbix_agentd|параметрах]] ​компонент отсутствуют. Для ознакомления с новыми необязательными параметрами агента, смотрите раздел [[:​ru/​manual/​introduction/​whatsnew320#​параметры_конфигурации|Что нового]].+Для получения более подробных сведений смотрите ​заметки по обновлению [[:​ru/​manual/​installation/upgrade_notes_340#​параметры_конфигурации|обязательных изменений]]. 
 + 
 +Для ознакомления с новыми необязательными параметрами, пожалуйста, смотрите раздел [[:​ru/​manual/​introduction/​whatsnew340#​параметры_конфигурации|Что нового]].
  
 == 7 Запустите процессы Zabbix == == 7 Запустите процессы Zabbix ==
Line 78: Line 93:
   # service zabbix-proxy start   # service zabbix-proxy start
   # service zabbix-agent start   # service zabbix-agent start
 +
 +== 8 Очистите cookies и кэш в веб-браузере ==
 +
 +После обновления вам, возможно,​ потребуется очистить cookies веб-браузера и кэш веб-браузера,​ чтобы Zabbix веб-интерфейс работал правильно.
 +
 +=== Обновление между минорными версиями ===
 +
 +Имеется возможность обновления минорные версии 3.4.x (например,​ с 3.4.1 на 3.4.3). Процедура очень проста.
 +
 +Для минорного обновления Zabbix, пожалуйста,​ выполните:​
 +
 +  $ sudo apt install --only-upgrade '​zabbix.*'​
 +
 +Для обновления минорной версии Zabbix сервера,​ пожалуйста,​ выполните:​
 +
 +  $ sudo apt install --only-upgrade '​zabbix-server.*'​
 +
 +Для обновления минорной версии Zabbix агента,​ пожалуйста,​ выполните:​
 +
 +  $ sudo apt install --only-upgrade '​zabbix-agent.*'​