Zabbix Documentation 4.2

3.04.05.0 (current)| In development:5.2 (devel)| Unsupported:1.82.02.22.43.23.44.24.4Guidelines

User Tools

Site Tools


manual:appliance

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:appliance [2017/09/18 08:12]
martins-v updating version numbers
manual:appliance [2018/11/09 09:11] (current)
martins-v fixing typo
Line 3: Line 3:
 === Overview === === Overview ===
  
-As an alternative to setting up manually or reusing an existing server for Zabbix, users may [[http://​www.zabbix.com/​download.php#​appliance|download]] a Zabbix appliance or Zabbix appliance installation CD image. Zabbix appliance installation CD could be used for instant deployment of Zabbix server (MySQL), Zabbix server (PostgreSQL),​ Zabbix proxy (MySQL) and Zabbix proxy (SQLite 3).+As an alternative to setting up manually or reusing an existing server for Zabbix, users may [[http://​www.zabbix.com/​download_appliance|download]] a Zabbix appliance or Zabbix appliance installation CD image. Zabbix appliance installation CD could be used for instant deployment of Zabbix server (MySQL), Zabbix server (PostgreSQL),​ Zabbix proxy (MySQL) and Zabbix proxy (SQLite 3).
  
-Zabbix ​Appliance ​virtual machines have prepared Zabbix server with MySQL support. It is built using Zabbix appliance installation CD.+Zabbix ​appliance ​virtual machines have prepared Zabbix server with MySQL support. It is built using Zabbix appliance installation CD.
  
 |{{:​manual:​installation_cd_boot_menu.png?​600|}}| |{{:​manual:​installation_cd_boot_menu.png?​600|}}|
Line 15: Line 15:
 Zabbix appliance and installation CD versions are based upon the following Ubuntu versions: ​ Zabbix appliance and installation CD versions are based upon the following Ubuntu versions: ​
 ^Zabbix appliance version^Ubuntu version^ ^Zabbix appliance version^Ubuntu version^
-|3.4.0|14.04.3  |+|4.0.0|16.04.3  |
  
 Zabbix appliance is available in the following formats: Zabbix appliance is available in the following formats:
Line 34: Line 34:
 The appliance has been built using standard Ubuntu/​Debian feature called Preseed files. The appliance has been built using standard Ubuntu/​Debian feature called Preseed files.
  
 +<note tip>If the appliance fails to start up in Hyper-V, you may want to press ''​Ctrl+Alt+F2''​ to switch tty sessions.</​note>​
 === - Changes to Ubuntu configuration === === - Changes to Ubuntu configuration ===
  
Line 42: Line 43:
 Official Zabbix [[manual:​installation:​install_from_packages#​debianubuntu|repository]] has been added to ///​etc/​apt/​sources.list//:​ Official Zabbix [[manual:​installation:​install_from_packages#​debianubuntu|repository]] has been added to ///​etc/​apt/​sources.list//:​
   ## Zabbix repository   ## Zabbix repository
-  deb http://​repo.zabbix.com/​zabbix/​3.4/​ubuntu ​trusty ​main +  deb https://​repo.zabbix.com/​zabbix/​4.0/​ubuntu ​xenial ​main 
-  deb-src ​http://​repo.zabbix.com/​zabbix/​3.4/​ubuntu ​trusty ​main+  deb-src ​https://​repo.zabbix.com/​zabbix/​4.0/​ubuntu ​xenial ​main
   ​   ​
 == - Firewall == == - Firewall ==
Line 53: Line 54:
   * Opened SNMP trap port (162 UDP);   * Opened SNMP trap port (162 UDP);
   * Opened outgoing connections to NTP port (53 UDP);   * Opened outgoing connections to NTP port (53 UDP);
-  * ICMP pakets ​limited to 5 packets per second;+  * ICMP packets ​limited to 5 packets per second;
   * All other incoming connections are dropped.   * All other incoming connections are dropped.
  
Line 115: Line 116:
 System: System:
   * appliance:​zabbix   * appliance:​zabbix
 +
 +<note important>​Use "sudo su" command with "​appliance"​ user name password to get root access rights.</​note>​
 +
 +<note important>​LiveCD comes without any password and uses the **ubuntu** user to log in into the console.</​note>​
  
 Database: Database:
Line 200: Line 205:
  
 The appliance Zabbix packages may be upgraded. To do so, run: The appliance Zabbix packages may be upgraded. To do so, run:
-  sudo apt-get --only-upgrade ​install ​zabbix*+  sudo apt install ​--only-upgrade ​'zabbix.*
 === - Naming, init and other scripts === === - Naming, init and other scripts ===
  
Line 285: Line 291:
 == - HDD/flash image (raw) == == - HDD/flash image (raw) ==
  
-  dd if=./zabbix_appliance_3.4.0_x86_64.raw of=/dev/sdc bs=4k conv=fdatasync+  dd if=./zabbix_appliance_4.0.0_x86_64.raw of=/dev/sdc bs=4k conv=fdatasync
   ​   ​
 Replace ///​dev/​sdc//​ with your Flash/HDD disk device. Replace ///​dev/​sdc//​ with your Flash/HDD disk device.
 === - Known issues === === - Known issues ===