Zabbix Documentation 3.0

3.04.04.45.0 (current)| In development:5.2 (devel)| Unsupported:1.82.02.22.43.23.44.2Guidelines

User Tools

Site Tools


manual:appendix:compatibility

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:appendix:compatibility [2016/03/08 06:40]
martins-v changes may be needed in logging parameters
manual:appendix:compatibility [2020/02/05 07:14]
marinagen fixed wording
Line 1: Line 1:
-==== 11 Version compatibility ====+==== 12 Version compatibility ====
  
 === Supported agents === === Supported agents ===
  
-Older agents from Zabbix 1.x and previous ​versions of Zabbix ​2.x can still be used with Zabbix 3.0. It generally does not require any configuration changes on the agent sideapart from parameters related to [[:​manual/​installation/​upgrade_notes_300#​changes_in_configuration_parameters_related_to_logging|logging]], which you may want to review.+Zabbix ​agents from previous Zabbix ​versions are compatible ​with Zabbix 3.0. However, you may need to review ​the configuration of older agents as some parameters have changed, for example, parameters related to [[:​manual/​installation/​upgrade_notes_300#​changes_in_configuration_parameters_related_to_logging|logging]] ​for versions before 3.0.
  
-However, to take full advantage of new and improved items, improved performance and reduced memory usage, use the latest 3.0 agent.+To take full advantage of new and improved items, improved performance and reduced memory usage, use the latest 3.0 agent
 + 
 +Note that Zabbix agent newer than 3.0 cannot be used with Zabbix server 3.0
  
 === Supported Zabbix proxies === === Supported Zabbix proxies ===
  
-Only Zabbix 3.0 proxies ​may be used with Zabbix ​server. Zabbix 1.8, 2.0, 2.2 and 2.4 proxies ​are not supported with Zabbix 3.0 server+Both Zabbix 3.0 proxies ​and Zabbix ​3.0 server ​are supported ​to work only with Zabbix 3.0 server ​and Zabbix 3.0 proxies ​respectively.
- +
-Zabbix 3.0 proxies ​may only be used with Zabbix 3.0 server. They will not work with 2.4 or older Zabbix server. +
 === Supported XML files === === Supported XML files ===