Sidebar

Zabbix Summit 2022
Register for Zabbix Summit 2022

11 Compatibilité de version

Agents supportés

Pour être compatible avec Zabbix 6.0, l'agent Zabbix ne doit pas être antérieur à la version 1.4 et ne doit pas être plus récent que la version 6.0.

Vous devrez peut-être revoir la configuration des agents plus anciens car certains paramètres ont changé, par exemple, les paramètres liés à la journalisation pour les versions antérieures à 3.0.

Pour tirer pleinement parti des dernières métriques, des performances améliorées et de l'utilisation réduite de la mémoire, utilisez le dernier agent pris en charge.

Agents 2 supportés

Les anciens agents Zabbix 2 à partir de la version 4.4 sont compatibles avec Zabbix 6.0 ; L'agent Zabbix 2 ne doit pas être plus récent que la version 6.0.

Notez que lors de l'utilisation de l'agent Zabbix 2 versions 4.4 et 5.0, l'intervalle par défaut de 10 minutes est utilisé pour actualiser les éléments non pris en charge.

Pour tirer pleinement parti des dernières métriques, des performances améliorées et de l'utilisation réduite de la mémoire, utilisez le dernier agent pris en charge 2.

Proxy Zabbix supportés

Pour être compatible avec Zabbix 6.0, le proxy doit être de la même version majeure ; ainsi, seuls les proxys Zabbix 6.0.x peuvent fonctionner avec le serveur Zabbix 6.0.x.

Il n'est plus possible de démarrer le serveur mis à niveau et de faire en sorte que des proxys plus anciens, mais non mis à niveau, transmettent des données à un serveur plus récent. Cette approche, qui n'a jamais été recommandée ni prise en charge par Zabbix, est désormais officiellement désactivée, car le serveur ignorera les données des proxys non mis à niveau. Voir aussi la procédure de mise à jour.

Les avertissements concernant l'utilisation de versions de démon Zabbix incompatibles sont consignés.

Fichiers XML supportés

Les fichiers XML antérieurs à la version 1.8 sont pris en charge pour l'importation dans Zabbix 6.0.

Dans le format d'exportation XML, les dépendances de déclencheur sont stockées par nom uniquement. S'il existe plusieurs déclencheurs portant le même nom (par exemple, ayant des gravités et des expressions différentes) ayant une dépendance définie entre eux, il n'est pas possible de les importer. Ces dépendances doivent être supprimées manuellement du fichier XML et rajoutées après l'importation.