Sidebar

Zabbix Summit 2022
Register for Zabbix Summit 2022

13 版本兼容性

支持的 agents

为了与 Zabbix 6.0 兼容,Zabbix agent不得低于 1.4 版本,也不得高于 6.0。

您可能需要检查旧 agents 的配置,因为某些参数已更改,例如与3.0 之前版本的日志记录相关的参数。

为了充分利用最新的指标、改进的性能和减少的内存使用,请使用最新支持的 agent。

支持的 agents 2

从 4.4 版开始的旧Zabbix agents 2 与 Zabbix 6.0 兼容;Zabbix agent 2不得高于 6.0。

请注意,当使用 Zabbix agent 2 版本 4.4 和 5.0 时,不支持的监控项默认刷新间隔 为10 分钟。

为了充分利用最新的指标、改进的性能和减少的内存使用,请使用最新支持的 agent 2。

支持的Zabbix proxies

为了兼容Zabbix 6.0,proxy 必须是同一个主版本; 因此只有 Zabbix 6.0.x proxies 可以与 Zabbix 6.0.x server 一起使用。

无法再启动升级 server,让旧的、但未升级的 proxies 向新 server 报告数据。Zabbix 从未推荐或支持这种方法,现在已正式禁用,同时 server 将忽略来自未升级 proxies 的数据。另请参阅升级过程

记录有关使用不兼容的 Zabbix 守护进程版本的警告。

支持的 XML 文件

Zabbix 6.0 支持导入不低于 1.8 版本的 XML 文件。

在 XML 导出格式中,触发器依赖项仅按名称存储。如果有多个具有相同名称的触发器(例如,具有不同的严重性和表达式)并且在它们之间定义了依赖关系,则无法导入它们。此类依赖项必须从 XML 文件中手动删除,并在导入后重新添加。