Zabbix Documentation 4.0

3.04.04.24.4 (current)| In development:5.0 (devel)| Unsupported:1.82.02.22.43.23.4Guidelines

User Tools

Site Tools


Sidebar

fr:manual:appendix:compatibility

13 Compatibilité de version

Agents supportés

Les agents Zabbix à partir de la version 1.4 sont compatibles avec Zabbix 4.0. Toutefois, il se peut que vous deviez revoir la configuration des anciens agents lorsque certains paramètres ont été modifiés, tels que ceux liés à la journalisation pour les versions antérieures à 3.0.

Pour tirer pleinement parti des éléments nouveaux et améliorés, des performances améliorées et de la réduction de l'utilisation de la mémoire, utilisez le dernier agent 4.0.

Proxy Zabbix supportés

Le serveur Zabbix 4.0.x ne peut fonctionner qu'avec les proxys Zabbix 4.0.x. Les proxys Zabbix 4.0.x ne peuvent fonctionner qu'avec le serveur Zabbix 4.0.x.

Il est connu qu'il est possible de démarrer un serveur mis à jour et d'avoir les proxy plus anciens, mais non mis à jour, ils transmettent les données à un serveur plus récent (les proxys ne peuvent par contre pas actualiser leur configuration). Cependant, cette approche n’est pas recommandée et n’est pas supportée par Zabbix et son choix est à vos risques et périls. Pour plus d'informations, voir la procédure de mise à jour.

Fichiers XML supportés

Les fichiers XML, exportés avec les versions 1.8, 2.0, 2.2, 2.4, 3.0, 3.2 et 3.4 sont supporté pour l'import dans Zabbix 4.0.

Dans le format d'export XML de Zabbix 1.8, les dépendances de déclencheurs sont uniquement stockées par nom. S'il existe plusieurs déclencheurs portant le même nom (par exemple, ayant des gravités et des expressions différentes) et ayant une dépendance définie entre eux, il est impossible de les importer. Ces dépendances doivent être supprimées manuellement du fichier XML et rajoutées après l'import.

Les avertissements concernant l'utilisation de versions incompatibles du démon Zabbix sont loggés depuis Zabbix 4.0.8.