Sidebar

zh:manual:appendix:compatibility

13 版本兼容性

支持的agents

从1.4版开始的Zabbix agents与Zabbix 4.0兼容。但是,你可能需要检查旧代理的配置,因为某些参数已更改。 例如,3.0之前的版本,与logging 相关的参数: logging

要充分利用新的和改进的项目,提高性能和减少内存使用,请使用最新的4.0 agent。

支持的Zabbix proxies

Zabbix 4.0 proxies和Zabbix 4.0 server只分别支持Zabbix 4.0 server和Zabbix 4.0 proxies一起工作.

众所周知,可以启动升级后的server,使用尚未升级的proxies给新的server报告数据(proxies无法刷新其配置)。 但是,不推荐使用这种方法,Zabbix不支持这种方法,选择它完全由你自己承担风险。更多详细说明,请查看升级步骤 upgrade procedure.

支持的XML文件

在Zabbix 4.0中支持导入1.8, 2.0, 2.2, 2.4, 3.0, 3.2和3.4的XML文件.

在Zabbix 1.8 XML导出格式中, 触发依赖仅由名称存储。如果有几个具有相同名称的triggers(例如,具有不同的严重性和表达式),它们之间定义了依赖关系,则无法导入它们。 必须从XML文件中手动删除这些依赖关系,并在导入后重新添加。