Sidebar

manual:appendix:compatibility

13 Version compatibility

Supported agents

To be compatible with Zabbix 5.2, Zabbix agent must not be older than version 1.4 and must not be newer than 5.2.

You may need to review the configuration of older agents as some parameters have changed, for example, parameters related to logging for versions before 3.0.

To take full advantage of the latest metrics, improved performance and reduced memory usage, use the latest supported agent.

Supported agents 2

Older Zabbix agents 2 from version 4.4 and 5.0 are compatible with Zabbix 5.2.x (except 5.2.0, see known issues); Zabbix agent 2 must not be newer than 5.2.

Note that when using Zabbix agent 2 versions 4.4 and 5.0, the default interval of 10 minutes is used for refreshing unsupported items.

To take full advantage of the latest metrics, improved performance and reduced memory usage, use the latest supported agent 2.

Supported Zabbix proxies

To be compatible with Zabbix 5.2, the proxy must be of the same major version; thus only Zabbix 5.2.x proxies can work with Zabbix 5.2.x server.

It is no longer possible to start the upgraded server and have older, yet unupgraded proxies report data to a newer server. This approach, which was never recommended nor supported by Zabbix, now is officially disabled, as the server will ignore data from unupgraded proxies. See also the upgrade procedure.

Warnings about using incompatible Zabbix daemon versions are logged.

Supported XML files

XML files not older than version 1.8 are supported for import in Zabbix 5.2.

In the XML export format, trigger dependencies are stored by name only. If there are several triggers with the same name (for example, having different severities and expressions) that have a dependency defined between them, it is not possible to import them. Such dependencies must be manually removed from the XML file and re-added after import.