Zabbix Documentation 5.0

3.04.04.45.0 (current)| In development:5.2 (devel)| Unsupported:1.82.02.22.43.23.44.2Guidelines

User Tools

Site Tools


manual:installation:requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
manual:installation:requirements [2020/05/21 15:26]
marinagen [ZBX-17767] Minimum screen width for frontend.
manual:installation:requirements [2020/05/22 05:57] (current)
wiper [Agent 2] removed Go, as it is build, not runtime requirement
Line 112: Line 112:
  
 ^Requirement^Status^Description^ ^Requirement^Status^Description^
-| //​Go// ​        ​|Mandatory ​ | Version 1.13 or later is required. ​ | 
 |//​libpcre// ​    ​|Mandatory ​ | PCRE library is required for [[https://​en.wikipedia.org/​wiki/​Perl_Compatible_Regular_Expressions|Perl Compatible Regular Expression]] (PCRE) support.\\ The naming may differ depending on the GNU/Linux distribution,​ for example '​libpcre3'​ or '​libpcre1'​. Note that you need exactly PCRE (v8.x); PCRE2 (v10.x) library is not used.  | |//​libpcre// ​    ​|Mandatory ​ | PCRE library is required for [[https://​en.wikipedia.org/​wiki/​Perl_Compatible_Regular_Expressions|Perl Compatible Regular Expression]] (PCRE) support.\\ The naming may differ depending on the GNU/Linux distribution,​ for example '​libpcre3'​ or '​libpcre1'​. Note that you need exactly PCRE (v8.x); PCRE2 (v10.x) library is not used.  |
 |//​OpenSSL// ​    ​|Optional ​  | Required when using encryption.\\ OpenSSL 1.0.1 or later is required on UNIX platforms.\\ The OpenSSL library must have PSK support enabled. LibreSSL is not supported.\\ On Microsoft Windows systems OpenSSL 1.1.1 or later is required. | |//​OpenSSL// ​    ​|Optional ​  | Required when using encryption.\\ OpenSSL 1.0.1 or later is required on UNIX platforms.\\ The OpenSSL library must have PSK support enabled. LibreSSL is not supported.\\ On Microsoft Windows systems OpenSSL 1.1.1 or later is required. |