Zabbix Documentation 4.4

3.04.04.4 (current)| In development:5.0 (devel)| Unsupported:1.82.02.22.43.23.44.2Guidelines

User Tools

Site Tools


manual:installation:requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
manual:installation:requirements [2019/06/27 11:00]
lexas libcurl version requirements updated
manual:installation:requirements [2019/10/31 12:15] (current)
martins-v agent2 requirement update
Line 57: Line 57:
 |//​SQLite// ​ |3.3.5 or later  |SQLite is only supported with Zabbix proxies. Required if SQLite is used as Zabbix proxy database. ​ | |//​SQLite// ​ |3.3.5 or later  |SQLite is only supported with Zabbix proxies. Required if SQLite is used as Zabbix proxy database. ​ |
  
-<note important>​IBM DB2 and TimescaleDB ​support is experimental!</​note>​+<note important>​IBM DB2 support is experimental!</​note>​
  
 == Frontend == == Frontend ==
Line 105: Line 105:
 |//​libssh2// ​    |:::| Required for SSH support. Version 1.0 or higher.| |//​libssh2// ​    |:::| Required for SSH support. Version 1.0 or higher.|
 |//​fping// ​      |:::| Required for [[manual:​config:​items:​itemtypes:​simple_checks#​icmp_pings|ICMP ping items]].| |//​fping// ​      |:::| Required for [[manual:​config:​items:​itemtypes:​simple_checks#​icmp_pings|ICMP ping items]].|
-|//​​libcurl//​ ​    |:::| Required for web monitoring, VMware monitoring, SMTP authentication,​ ''​​web.page.*''​​ Zabbix agent [[:manual/config/items/itemtypes/zabbix_agent|items]],​ HTTP agent items and Elasticsearch (if used). Version 7.28.0 or higher is recommended.\\ Libcurl version requirements:​\\ - SMTP authentication:​ version ​7.20.0 or higher\\ - Elasticsearch:​ version ​7.28.0 or higher  ​+|//​​libcurl//​ ​    |:::| Required for web monitoring, VMware monitoring, SMTP authentication,​ ''​​web.page.*''​​ Zabbix agent [[:​manual/​config/​items/​itemtypes/​zabbix_agent|items]],​ HTTP agent items and Elasticsearch (if used). Version 7.28.0 or higher is recommended.\\ Libcurl version requirements:​\\ - SMTP authentication:​ version ​7.20.0 or higher\\ - Elasticsearch:​ version ​7.28.0 or higher ​ |
-|//​libiksemel// ​ |:::| Required for Jabber support.|+
 |//​libxml2// ​    |:::| Required for VMware monitoring and XML XPath preprocessing. ​ | |//​libxml2// ​    |:::| Required for VMware monitoring and XML XPath preprocessing. ​ |
 |//​net-snmp// ​   |:::| Required for SNMP support. ​ | |//​net-snmp// ​   |:::| Required for SNMP support. ​ |
 +
 +== Agent 2 ==
 +
 +Agent 2 is supported on 64-bit Linux.
 +
 +^Requirement^Description^
 +|//​OpenSSL// ​ |Required when using encryption. Version 1.1.0 or higher. ​ |
  
 == Java gateway == == Java gateway ==