Sidebar

manual:installation:upgrade_notes_540

10 Upgrade notes for 5.4.0

Zabbix 5.4.0 is not released yet.

Critical

Timescale DB

The minimum required version of Timescale DB has been upped from 1.0 to 1.5. Also PostgreSQL 10.2 or higher is required with Timescale DB.

Informational

Host availability data

All data about host availability have been moved from the host level to the level of individual interfaces. During database upgrade all previous host availability data will be lost. New interface availability initially will be set to 'unknown' and then updated after some time.

Note that the server-proxy data exchange protocol has also been changed.

Direct connections to database removed from pollers

Calculated, aggregated and internal checks are now performed by the new history poller process. The StartHistoryPollers value should be increased if history pollers are too busy, but should be kept low if possible to avoid unnecessary connections to database.

New availability manager process has been introduced. All processes queue host availability updates to the availability manager and that queue is flushed by the availability manager to the database every 5 seconds.

You can monitor the new processes using the zabbix[process,<type>] internal item.

Naming in JavaScript objects

Naming in additional JavaScript objects has been changed.

Hidden PSK data for hosts and proxies

PSK identity and PSK fields in host and proxy configuration are now write-only. Once saved, these values cannot be viewed again in the frontend or retrieved through API but can be replaced with new values. For hosts, PSK identity and PSK will no longer be exported.

Value mapping on template/host level

As value mapping has been moved to template/host level, there is no global value mapping anymore. During the upgrade, all global value maps that are used in items will be copied to the respective template or host.